I wanted to contribute to this message board. I found all the information I needed to configure my device here and since I had to pull a lot of things together and some trial and error I figured I could share what worked for me. It was a little frustrating because every config I could find was a post saying "here is what I have but it is still not working." So here is my contribution of a working configuration.
My dsl config is set to auto so they don't show in the running config, nice part is you don't have to guess whether or not it is ADSL or VDSL.
But to get there you have to enter:
Controller vdsl 0
operating mode auto
Vlan tagging was the last thing that kept me from getting connected. Century Link wants to see tags (201) on the traffic. So you will see the sub-interface INTERFACE ETHERNET 0.1
With encapsulation dot1Q 201
WORKING CONFIGURATION with NAT
Building configuration...
Current configuration : 2397 bytes
Last configuration change at 01:29:22 UTC Thu Mar 13 2014
version 15.2
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
hostname Cisco887VA
boot-start-marker
boot-end-marker
enable secret 5 ****************
enable password *********
no aaa new-model
memory-size iomem 10
ip dhcp excluded-address 192.168.2.1 192.168.2.100
ip dhcp pool my-pool
import all
network 192.168.2.0 255.255.255.0
default-router 192.168.2.1
dns-server 205.171.3.65 8.8.8.8
lease 0 2
no ip domain lookup
ip domain name ********.***
ip name-server 205.171.3.65
ip name-server 8.8.8.8
ip cef
no ipv6 cef
controller VDSL 0
interface Ethernet0
description Outside DSL interface
no ip address
no ip redirects
no ip unreachables
no ip proxy-arp
interface Ethernet0.1
description Outside DSL interface sub interface for encapsulation
encapsulation dot1Q 201
no ip redirects
no ip unreachables
no ip proxy-arp
ip flow ingress
ip virtual-reassembly in
pppoe enable group global
pppoe-client dial-pool-number 1
interface ATM0
no ip address
shutdown
no atm ilmi-keepalive
interface FastEthernet0
no ip address
interface FastEthernet1
no ip address
interface FastEthernet2
no ip address
interface FastEthernet3
no ip address
shutdown
interface Vlan1
description Vlan for the primary network operating on the inside
ip address 192.168.2.1 255.255.255.0
ip nat inside
ip virtual-reassembly in
ip tcp adjust-mss 1412
interface Vlan201
no ip address
pppoe enable
pppoe-client dial-pool-number 1
interface Dialer0
ip address negotiated
ip mtu 1452
ip nat outside
ip virtual-reassembly in
encapsulation ppp
dialer pool 1
dialer idle-timeout 240
dialer fast-idle 240
dialer-group 1
ppp authentication pap callin
ppp chap hostname ***********
ppp chap password 0 ************
ppp pap sent-username ************* password 0 ************
no cdp enable
ip forward-protocol nd
no ip http server
no ip http secure-server
ip nat inside source list 1 interface Dialer0 overload
ip route 0.0.0.0 0.0.0.0 Dialer0
access-list 1 permit 192.168.2.0 0.0.0.255
dialer-list 1 protocol ip permit
line con 0
no modem enable
line aux 0
line vty 0 4
password ********
login
transport input all
end
↧